Loading...
Wiki 2018-01-16T12:17:52+00:00

Getting Started

This section explains how to connect your FLUO to your computer and upload your first sketch.

The FLUO can be programmed using the Arduino IDE FLUO Edition. This IDE is a modified version of the Arduino IDE with support for Fluo Technology Boards and FLUO exclusive Libraries that will allow you to program your FLUO with a USB cable and wirelessly (OTA).

The most common way of programming your FLUO is to first program the ATmega644p and then use FluoTube to communicate with the ESP32, but it’s also possible to program the ESP32 with the same IDE.

Before we begin, you must first install Arduino IDE Fluo Edition on your computer, you can follow the instructions for your operating system HERE.

Arduino IDE FLUO Edition

The Open Source Arduino Software (IDE) makes it easy to write code and upload it to your FLUO. The IDE is compatible with macOS, Windows and Linux. The programming environment is written in Java and it’s based on Processing and other other Open Source software. In this special edition we added support for FLUO Technology Boards. Considering the particular nature of our boards, at the moment we are not  able to use the classic Arduino Board Manager, therefore we provide you with the classic Arduino IDE distributed by Arduino with added support for FLUO boards.

Downloads

Make sure you download the right IDE for your operating system:

Terms of Use

BY DOWNLOADING THIS SOFTWARE YOU AGREE TO THE FOLLOWING TERMS AND CONDITIONS: THE ARDUINO IDE FLUO EDITION SOFTWARE IS PROVIDED TO YOU “AS IS” AND WE MAKE NO EXPRESS OR IMPLIED WARRANTIES WHATSOEVER WITH RESPECT TO ITS FUNCTIONALITY, OPERABILITY, OR USE, INCLUDING, WITHOUT LIMITATION, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR INFRINGEMENT. WE EXPRESSLY DISCLAIM ANY LIABILITY WHATSOEVER FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES, INCLUDING, WITHOUT LIMITATION, LOST REVENUES, LOST PROFITS, LOSSES RESULTING FROM BUSINESS INTERRUPTION OR LOSS OF DATA,REGARDLESS OF THE FORM OF ACTION OR LEGAL THEORY UNDER WHICH THE LIABILITY MAY BE ASSERTED, EVEN IF ADVISED OF THE POSSIBILITY OR LIKELIHOOD OF SUCH DAMAGES.
THIS SOFTWARE IT IS DISTRIBUTED BY ARDUINO UNDER A GNU GPL v2 LICENSE:
ADDITIONAL INFORMATION AND SOURCE CODE CAN BE FOUND HERE:

Installation Guide

Select your operating system for step-by-step instructions:

macOS

1. Download and extract the software:

Download the Arduino IDE FLUO Edition software and extract the file by double-clicking on it. If you use Safari, it will be automatically extracted.


2. Copy it to your Applications folder:

Once the file is extracted, move ArduinoFluoEd into your Applications folder and double-click to open it.

Windows

1. Download and install Bonjour Print Services v2.0.2:


2. Download and extract the software:

Download the Arduino IDE FLUO Edition software and extract the file.

3. Open the software:

Duble click on ArduinoFluoEdition.exe to open it. You won’t need to install it, keep the folder in a safe place and create a shortcut for your desktop if you need to.

If you have a version of Windows older than Windows 10, you need to install the driver for FLUO boards. You can follow this GUIDE to install it.

When asked for the drivers folder, you should point to the folder that is inside the compressed file you downloaded, next to ArduinoFluoEdition.exe.

LINUX

This tutorial is only valid for Debian-based Linux distributions.

1. Execute commands in the Terminal:

Open Terminal and input the following commands. After pasting the command, press ten Enter key:


2. Install Vim editor:

3. Create the file 90-extraacl.rules in the /etc/udev/rules.d folder:

4. Paste the following lines:

This will allow a generic user to use of the serial ports of the operating system. You have to replace USER
with your Linux username. To quit Vim, type :quit and press Enter:

5. Grant yourself permissions to the tty and dialout groups:

6. Remove ModemManager from your system in case it’s installed on your computer:

7. Reload the udev rules:

Now you should be able to properly build and upload a sketch to your board. If you have trouble,
please reboot your system to complete the setup.

8. Install Java JDK:

9. Install PySerial:

10. Download and extract the software:

Download the Arduino IDE FLUO Edition software.

Extract the file.


11. Open the software:

Double-click and open the file.

USB Programming

After instaling Arduino IDE Fluo Edition, connect your FLUO to your computer using a USB micro-B cable. This type of USB cable is commonly used by smartphones and it’s widely available.

The USB connection provides power to your FLUO and allows you to establish communication between both devices. The FLUO automatically draws power from either the USB cable or an external power supply. After you connect the FLUO to your computer using the USB micro-B cable, the green power LED (labeled ON) should turn on.

1. Open your first sketch:

Open the LED blink example sketch: File > Examples > 01.Basics > Blink.

2. Select your board:

Go to Tools > Board and select your FLUO (AVR) board from de dropdown menu.

3. Select your communications port:

Select the serial device of the board from the Tools > Port menu.

macOS: It will likely be /dev/cu.usbmodemFAxxxxx (FLUO WI-FI (AVR)).
In general it will have the name (FLUO WI-FI(AVR)) because it’s linked to the USB product and vendor IDs.

Windows: It will likely be COM3 or higher.

Linux: It will likely be /dev/ACM0 or higher (ACM0 and ACM1 are usually reserved for hardware serial ports).

If you’re not sure which port correspond to your FLUO, you can try to connect and disconnect your FLUO and compare the results on the list of ports.

4. Select the port mode:

Select Port Mode -> Serial
Serial is default channel to program the board. The other channel on the list is used during recovery mode via Wi-Fi

5. Upload your sketch:

Click on the Upload button (the one with the arrow) and wait for a few seconds until the upload process is complete. You will see that the RX and TX LEDs on your FLUO will flash during the upload process. If the upload process is successful, the message “Done uploading.” will appear on the status bar.

A few seconds after the upload finishes finishes, you should see the orange LED of pin 13 on your FLUO blinking. If it does, congratulations! Your FLUO is ready for you to upload your own code!

If you have trouble configuring your FLUO, please check the Troubleshooting section.

IoT Configuration

1. Connect to your FLUO:

Open the Wi-Fi configuration settings on your computer or smartphone and connect to FLUO WI-FI (FirstConfig).

Open your web browser and go to the following IP address: 192.168.4.1. Click on Configure Wi-Fi to begin configuring your Wi-Fi connection.

2. Connecting your FLUO to your Wi-Fi network:

Select your Wi-Fi network name, type the password and give a name to your FLUO. Click save when you’re done to connect to the Wi-Fi network. If you can’t see your Wi-Fi network, click Scan to perform another search.

Select your Wi-Fi network name, type the password and give a name to your FLUO. Click save when you’re done to connect to the Wi-Fi network. If you can’t see your Wi-Fi network, click Scan to perform another search.

Once you are successfully connected to your Wi-Fi network, click on the IoT button. Once the FLUO is in IoT mode, your computer or smartphone will disconnect from your FLUO and connect back again to your Wi-Fi network. The connection between your computer or smartphone and the FLUO will now be established through your Wi-Fi network.

After you enter IoT mode, you need to reset your FLUO by pressing the RESET button for 5 seconds or disconnect it from the power supply and connecting it back again.

After resetting your FLUO, it will be accessible though two different addresses: NAME_OF_YOUR_FLUO.local or another IP address such as the one shown on the following page.

You will now be able to access the IoT panel for your FLUO, where you will have control over your FLUO’s inputs and outputs.

FLUO Pinout